FreeBSD man pages : savecore (8)
SAVECORE(8) FreeBSD System Manager's Manual SAVECORE(8)
savecore - save a core dump of the operating system
savecore [-fkvz] [-N system] directory
The savecore utility copies the currently running kernel and its associ-
ated core dump into directory, and enters a reboot message and informa-
tion about the core dump into the system log.
The options are as follows:
-c Clear the dump, so that future invocations of savecore will
-f Force a dump to be taken even if the dump doesn't appear correct
or there is insufficient disk space.
-k Do not clear the dump after saving it.
-N Use system as the kernel instead of the running kernel (as deter-
mined from getbootfile(3)).
-v Print out some additional debugging information.
-z Compress the core dump and kernel (see gzip(1)).
The savecore utility checks the core dump in various ways to make sure
that it is current and that it corresponds to the currently running sys-
tem. If it passes these checks, it saves the core image in
directory/vmcore.# and the system in directory/kernel.# The ``#'' is the
number from the first line of the file directory/bounds, and it is incre-
mented and stored back into the file each time savecore successfully
The savecore utility also checks the available disk space before attempt-
ing to make the copies. If there is insufficient disk space in the
filesystem containing directory, or if the file directory/minfree exists
and the number of free kilobytes (for non-superusers) in the filesystem
after the copies were made would be less than the number in the first
line of this file, the copies are not attempted.
If savecore successfully copies the kernel and the core dump, the core
dump is cleared so that future invocations of savecore will ignore it.
The savecore utility is meant to be called near the end of the initial-
ization file /etc/rc (see rc(8)).
The minfree code does not consider the effect of compression.
gzip(1), getbootfile(3), dumpon(8), syslogd(8)
The savecore utility appeared in 4.1BSD.
FreeBSD 4.8 September 23, 1994 FreeBSD 4.8